A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 15:23 PDT
Investigating
We have been made aware that the Integrations menu option under Platform Tools is currently not loading. ON24 technical resources have been engaged and are actively working to restore functionality.
NOTE: This does not impact any integration connections that are currently running.
Posted Mar 17, 2026 - 13:05 PDT
This incident affected: Producer: Elite, Engagement Hub, Target, Forums, Go Live.