Presenter List not loading

Resolved

This incident has now been resolved. Thank you for your patience.
Posted Aug 12, 2025 - 11:19 PDT

Investigating

We have been made aware that the presenter list window in Elite Studio is not loading. The ON24 technical and engineering teams are currently investigating as a priority.
Posted Aug 12, 2025 - 10:50 PDT
This incident affected: Presenter: Presentation Interface (PMXD or Elite Studio).